[ad_1]

Netgear fixed a bug affecting multiple WiFi router models, including Wireless AC NighthawkWireless AX Nighthawk (WiFi 6), and Wireless AC router models.

The vendor only said that the flaw is a pre-authentication buffer overflow vulnerability and urged customers to address the firmware of their devices as soon as possible. An attacker can exploit this vulnerability without requiring permissions or user interaction.

Threat actors often exploit this kind of issue to trigger a DoS condition or to execute arbitrary code on vulnerable devices.

“NETGEAR has released fixes for a pre-authentication buffer overflow security vulnerability” reads the advisory published by the company. “NETGEAR strongly recommends that you download the latest firmware as soon as possible.”

Below is the list of fixes released by the company for the specific product models:

  • RAX40 fixed in firmware version 1.0.2.60
  • RAX35 fixed in firmware version 1.0.2.60
  • R6400v2 fixed in firmware version 1.0.4.122
  • R6700v3 fixed in firmware version 1.0.4.122
  • R6900P fixed in firmware version 1.3.3.152
  • R7000P fixed in firmware version 1.3.3.152
  • R7000 fixed in firmware version 1.0.11.136
  • R7960P fixed in firmware version 1.4.4.94
  • R8000P fixed in firmware version 1.4.4.94
Netgear Nighthawk R6700v3

Below are step-by-step instructions to download the latest firmware for impacted router models:

  1. Visit NETGEAR Support.
  2. Start typing your model number in the search box, then select your model from the drop-down menu as soon as it appears.
    If you do not see a drop-down menu, make sure that you entered your model number correctly, or select a product category to browse for your product model.
  3. Click Downloads.
  4. Under Current Versions, select the download whose title begins with Firmware Version.
  5. Click Download.
  6. Follow the instructions in your product’s user manual, firmware release notes, or product support page to install the new firmware.

“The pre-authentication buffer overflow vulnerability remains if you do not complete all recommended steps. NETGEAR is not responsible for any consequences that could have been avoided by following the recommendations in this notification.” concludes the advisory.

The vendor did don reveal if the flaw has been actively exploited in attacks in the wild.

Follow me on Twitter: @securityaffairs and Facebook and Mastodon

Pierluigi Paganini

(SecurityAffairs – hacking, Netgear)






[ad_2]

Source link